Up Next showing a show I am already up to date with

Doctor Who shows 100% watched but is still showing under Up Next. When I click on Progress, it’s showing the next episode in the list even though that doesn’t air until Friday:

First, please try to clear your cache using the uption to Reset Browser Data: Advanced Settings - Trakt

Also, see if when you watch something that show dissapears. You can just mark and unmark something as watched to test that too.

After I posted this, I found this other thread which seems to be the same issue:

I think this is a similar issue I am having. On the website (not a native iOS or Android app), on the Dashboard…in the Up Next section, when I click the checkmark to mark a shows episode as watched, they don’t disappear if I am up-to-date like they use to. They show that checkmark purple (in dark mode) and my show rating in the top right corner.

In this first screenshot, look at TV Shows “Below Deck” and “All American”. I have not marked them as watched.

In this next screenshot, the shows didn’t disappear, they show like I explained above and stay there…this isn’t the same behavior as before:

If you refresh the page, is the 100% show gone? If so, this seems like the correct behavior so that you know you’re 100% after marking the most recent episode watched.

If I do a hard refresh, yes, the shows that have been marked 100% (or up-to-date) are removed. But this wasn’t the behavior previously. Previously they would disappear (fade out) and the next show would “move up/over”. If that behavior was removed on purpose…that’s what I was after as an answer.

I have just one show that started showing up in the Up next which is 100% complete. It also shows up on the iOS app, and also in the progress with completed one’s hidden (progress/watched/added/asc?hide_completed=true) It might have something to do with the show release date being in the future.

Hi, I’m having a similar problem. I have reset the Trakt browser data & cleared my cache.

I also had Big Door Prize showing up, even though I’d hidden the second season, but re-hiding the season seemed to make it go away.

I didn’t specifically change this, but seems to be a side effect of some behind the scenes changes I made earlier this week for up next / progress. There is a lot more caching going on behind the scenes now to help speed it up.

1 Like

I created a new process that will refresh progress info for shows that have recently aired episodes. It is currently set to refresh within 6 hours of airing and I believe this should solve most of the issues with seeing shows with 100% sometimes.

There have been a lot of performance updates behind the scenes for progress and up next, so that is why some bugs are cropping up recently. We’ll continue to work through them.

2 Likes

Thanks for all your hard work!

Thanks for the update. I’ll just deal with having to refresh after marking some shows as watched…and I’ll also use the “show more” under that sections so that is shows 3 rows.

Man this is totally broken now. Mark a show watched and it does not go away even with a refresh. Still getting shows that I’m caught up on showing in Up Next. I’d much rather it be slower updating and removing an episode and work correctly. Revert all.

There is an unrelated bug we are tracking down right now.

I’m having the same issue. I’ve marked the same episode of Vanderpump Rules as watched twice now and it shows it’s marked as watched, but it doesn’t show up on my profile in my logged episodes and it still shows up when I view my up next/current shows.

The bug is now fixed.

I completed the show Fringe like three days ago but didn’t have any issues. Even now it’s still gone like it should.

Also didn’t have any issues with watches not appearing at all these past few days. Happy I missed it! Hahaha.

I hate to bring this issue back up since it was marked “Solved” but it seems the bug has returned. See my screenshot below. The show “Harry Wild” won’t go away even after a hard refresh (several times).

Did you try the link to reset progress cache posted above:

https://trakt.tv/settings/advanced